1. There is no such thing as a "pending" ban or Steam admin. Anyone threatening your account is a scammer trying to scare you. Read more.

Sign-in through Steam doesn't work on SteamRep main site?

Discussion in 'SteamRep General Discussion' started by PlyrStar93, Aug 21, 2016.

  1. PlyrStar93

    PlyrStar93 New User

    Messages:
    9
    Steam:
    STEAM_0:0:99352120
    Hi, is it just me or the "sign in through Steam" is not working on the SR main site?

    The one I'm referring to is this (not SR forum):
    sign-in-steamrep.png

    After I click on it, then "sign in" at Steam, it brings back to the SR site without me signed in.

    I've had this problem since about 2 to 3 days ago. Anyone else experiencing this issue? I can still sign in through Steam at anywhere else, including SR Forum but not the SR main site.
  2. Clive

    Clive SteamRep Admin

    Messages:
    6,433
    SteamRep Admin:
    STEAM_0:0:43668349
    It worked for me just now with no issues.
  3. Nebras

    Nebras New User

    Messages:
    250
    Steam:
    STEAM_0:0:92811415
    Try cleaning cookies for SR, if you're on chrome, go to settings, show advanced options, content settings then show all cookies and site data, search for SteamRep and clear, then try signing in
  4. PlyrStar93

    PlyrStar93 New User

    Messages:
    9
    Steam:
    STEAM_0:0:99352120
    I also asked two friends, while one friend did say he had no issue, the other said doesn't work for him either.
    I hate to believe it would be an account specific issue, but now I'm really not sure.

    If these worked for me, then I wouldn't have been making this thread.

    In fact, I already tried all browsers I have, all devices in my hand (my Windows 10 PC and iPad, a bunch of VM too), cleared all cookies+history+cache for the browsers, tried all these before posting this, and still can't sign in. Also I just clean installed a Windows 7 x64 with the latest Firefox and Chrome in a virtual machine and tried in there, and still can't sign in with such environment.
  5. Horse

    Horse Administrator SteamRep Admin

    Messages:
    72,694
    SteamRep Admin:
    STEAM_0:1:34690691
    Tried it - worked perfect for me.
  6. Nebras

    Nebras New User

    Messages:
    250
    Steam:
    STEAM_0:0:92811415
    Well, it works for me aswell, what happens if you click it without being signed in on Steam, does it still redirect you back?
  7. PlyrStar93

    PlyrStar93 New User

    Messages:
    9
    Steam:
    STEAM_0:0:99352120
    Redirects me back to the page before I signed in. The page (url) is still the one before sign in, and the "sign in through Steam" button is still there and I cannot check user's rep history.
  8. Roudydogg1

    Roudydogg1 Moderator; Neonheights Co-Owner SteamRep Moderator Friend Community

    Messages:
    902
    Steam:
    STEAM_0:0:58227918
    Join the club mate, I've been having issues as well. Waiting for some actual advice or else I would have made a post about ;)
  9. Lava

    Lava Public Relations SteamRep Admin

    Messages:
    5,709
    SteamRep Admin:
    STEAM_0:1:46187366
    Few questions:
    1. Are you getting any errors?
    2. Does it ask you to confirm signing in from the Steam website, or just redirect you straight here?
    3. Can you access any part of steamrep.com that requires login, such as historical data?
    4. Do you have relevant screenshots?
    5. Are you viewing the site through http or https?
    This could be hard to troubleshoot, but as far as I know there is no mechanism to stop people from signing into steamrep.com, even if you're a marked scammer and trade banned.
    Enstage likes this.
  10. PlyrStar93

    PlyrStar93 New User

    Messages:
    9
    Steam:
    STEAM_0:0:99352120
    Thanks for the follow up, Lava.

    Q1. Are you getting any errors?
    A: there was no error. It simply redirects me to the page before I logged in, still shows the green "sign-in through Steam", the main site and nothing else.

    Q2. Does it ask you to confirm signing in from the Steam website, or just redirect you straight here?
    A: Yes, it would take me to Steam to log in. The login page had URL like "https://steamcommunity.com/openid/login?openid.ns=..."

    Q3. Can you access any part of steamrep.com that requires login, such as historical data?
    Not for the main site, so I couldn't access historical data. However like I said, SteamRep forum (forums.steamrep.com) is fine.

    Q4. Do you have relevant screenshots?
    A: Click on thumbnails to view full images.
    (1) Before logging in:
    before-login.png

    (2) After clicking on "sign in through Steam" and it takes me to Steam for login:
    logging-in-through-steam.png

    (3) After clicking on "sign in" in the above page and it takes me back to SteamRep:
    after-login.png

    Q5. Are you viewing the site through http or https?
    A: http and https, tried both and got the same problem.
    Roudydogg1 and Enstage like this.
  11. PlyrStar93

    PlyrStar93 New User

    Messages:
    9
    Steam:
    STEAM_0:0:99352120
    Guys, I think it might be worth mentioning that my ISP has IPv6 enabled. I just tried some other network which only have IPv4 and I could sign in. Still, I don't know why this happens, but the fact that using different Internet connection lets me login made me dig a little bit into this.

    I use Comcast (AS7922/AS33491) and SteamRep is resolved into an IPv6 address.
    steamrep-ipv6.png

    So when IPv6 is enabled, I keep having this sign-in problem whatever device I use--my PC, iPad (3rd Gen with iOS 9.3.4, does support IPv6), and those VM I have tested. These are tested in my home Internet.

    If I disable IPv6 in my Internet settings and only use IPv4, then I can sign in normally. Also note that I'm still using my home Internet.

    While I now suspect IPv6 should be the cause, it still doesn't fully make sense. Like I said, the sign in through Steam function works just fine with SteamRep forum (has the same IP address resolved as the main site), and at least one other site that uses Steam sign in--namely SteamDB. However SteamRep main site doesn't correctly sign me in. With all these said, all these sites use Cloudflare. I tried my best to tell everything I know, so hope this is enough information.


    Do you have IPv6 enabled just as me? If that's the case, what if you disable it and try again? Are you able to log in when you only have IPv4 enabled on your Internet?
  12. Lava

    Lava Public Relations SteamRep Admin

    Messages:
    5,709
    SteamRep Admin:
    STEAM_0:1:46187366
    If you log in via IPv4 and then switch to IPv6, does it appear to log you out?
  13. PlyrStar93

    PlyrStar93 New User

    Messages:
    9
    Steam:
    STEAM_0:0:99352120
    Toggled IPv6 on and off for several times, also cleared cookies before each test. Refreshes are all performed by Ctrl+F5.
    • If I login through IPv4, keep the browser and login session, switch to IPv6 (either enable IPv6 in addition to IPv4, or change it to IPv6 only), refresh, then it still keeps my login session.
    • However, with a logged in session, if I restart the browser or just clear the cookies when IPv6 enabled (either in addition to IPv4, or IPv6 only) then refresh, it appears as logged out, I can't use functions that require login, and I won't be able to log in again.
    • If I have IPv6 first (again, either case), I just can't log in. At this point if I disable IPv6 and only enable IPv4, refresh (without having to restart browser or clear the cookies), then I can log in again.

    So, If I log in via IPv4 and then switch to IPv6, it doesn't just appear to log me out right away. I will need to clear the cookies or restart the browser (don't have to clear cookies) for the site to appear as logged out, and once it appears as logged out, I won't be able to log in unless I switch to IPv4 only.
  14. Horse

    Horse Administrator SteamRep Admin

    Messages:
    72,694
    SteamRep Admin:
    STEAM_0:1:34690691
    SR most likely isn't setup for IPv6 which is why this is happening to those of you with this issue.
    Hidden Content:
    **Hidden Content: Content of this hidden block can only be seen by members of (usergroups: Administrative, Moderating).**
  15. Roudydogg1

    Roudydogg1 Moderator; Neonheights Co-Owner SteamRep Moderator Friend Community

    Messages:
    902
    Steam:
    STEAM_0:0:58227918
    I've been on IPv6 for quite a few months, no issues until recently, (just for the record :) )
  16. Roudydogg1

    Roudydogg1 Moderator; Neonheights Co-Owner SteamRep Moderator Friend Community

    Messages:
    902
    Steam:
    STEAM_0:0:58227918
    If I disable IPV6 (both [IPv6 and IPv4] are enabled by default) I am as well able to log in then, which begs the question (for me anyway) why I never had the issue until sometime late last week
    PlyrStar93 and Enstage like this.